Goldsky - Increased database load is causing high latency for API server requests – Incident details

Increased database load is causing high latency for API server requests

Resolved
Operational
Started about 2 months agoLasted about 1 hour

Affected

Subgraphs

Degraded performance from 4:20 PM to 5:33 PM

API

Degraded performance from 4:20 PM to 5:33 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

    A database read replica was locked due to an automated maintenance system. We have implemented an immediate fix and are investigating the underlying causes to prevent future issues like this.

  • Investigating
    Update

    We've opened a support ticket with AWS. One of our database shards is under high load and our proxies are showing a high number of pending transactions.

  • Investigating
    Investigating
    We are currently investigating this incident.