Arweave Search Gateway: Stale data and Degraded Query Performance

Resolved
Operational
Started about 2 months ago Lasted 2 days

Affected

Arweave Search Gateway
Updates
  • Resolved
    Resolved

    The search gateway's query latencies and indexing rate has now stabilized. We're doing a set of final maintenance

    Rate limits have increased to 50 per 10s and will be raised further on Monday

  • Monitoring
    Monitoring

    We implemented a fix and are currently monitoring the result. Query speeds are still affected as we complete additional infrastructure upgrades.

  • Identified
    Identified

    A database upgrade for the Arweave Search Gateway API has failed, and is recovering. Query latency may be slower, and data will be stale during some parts of the recovery.

    Estimate recovery time may vary, from 2-10 hours.