Goldsky - Database connectivity and performance issues – Incident details

Database connectivity and performance issues

Resolved
Operational
Started 3 months agoLasted about 15 hours

Affected

API

Degraded performance from 8:47 AM to 11:24 PM

Dashboard

Degraded performance from 8:47 AM to 11:24 PM

Mirror

Degraded performance from 8:47 AM to 11:24 PM

Subgraph Sources

Degraded performance from 8:47 AM to 11:24 PM

Subgraphs

Degraded performance from 8:47 AM to 11:24 PM

API

Degraded performance from 8:47 AM to 11:24 PM

Updates
  • Resolved
    Resolved

    We have tuned our database backend and have recovered. All subgraph mirror pipelines should have the most up to date data at edge, and no data was lost.

  • Identified
    Identified

    We are currently investigating this incident. Some users are reporting that the GraphQL API for subgraphs has issues connecting to the database. Sometimes the dashboard is slow to load. Subgraph replication with mirror is lagging.

    We have opened a chat with AWS to help investigate our database.

    We have identified the root cause, measures are being applied but will take some time to complete.